Incident

CDN issue

Resolved | Nov 18, 2025 | 21:00 GMT+00:00

Cloudflare has confirmed the issue has resolved and all our services have been working without any issue, hence closing this issue.

Monitoring | Nov 18, 2025 | 12:55 GMT+00:00

Most services are now online, some may face occasional slowness. Traffic performance is steadily improving as Cloudflare services are restored.

Cloudflare status: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7

Open | Nov 18, 2025 | 11:54 GMT+00:00

All our services are impacted due to the Cloudflare incident, we are monitoring the situation. Cloudflare has acknowledge the issue and is working on mitigation.

Cloudflare status link : https://www.cloudflarestatus.com

Open | Nov 18, 2025 | 11:46 GMT+00:00

We are currently facing an issue with Cloudflare, where several services are incorrectly displayed as down even though they remain operational. This is a Cloudflare-related problem, and our team is actively monitoring the situation