Incident

Time outs in EU environment

Resolved | May 18, 2026 | 06:31 GMT+01:00

The issue has been resolved

Investigating | May 18, 2026 | 06:30 GMT+01:00

The issue has been resolved.

Investigating | Apr 23, 2026 | 19:35 GMT+01:00

We recently identified high latency and timeout errors affecting the EU Knowledge Base. Our team has stabilized the environment, and services have returned to normal. This issue was isolated strictly to the EU region."