Incident

Authentication Issues in Portal

Resolved | Dec 19, 2019 | 19:58 GMT+00:00

Auth0 service outage is now resolved and Document360 Portal login function is back to normal.

Identified | Dec 19, 2019 | 19:33 GMT+00:00

Our authentication partner Auth0 is experiencing some service outage, causing delayed response while logging in to Document360 Portal.