Incident

EU - Application slowness and timeout

Resolved | Apr 16, 2026 | 06:11 GMT+01:00

The systems are now operational and the issue is now resolved.

Monitoring | Mar 29, 2026 | 04:32 GMT+01:00

We’ve identified that a recent update to our caching system caused the slowdown. We’ve taken steps to address this and are keeping a close watch on the service to make sure everything stays running smoothly.

Identified | Mar 29, 2026 | 04:25 GMT+01:00

We’ve identified an issue in EU environment causing slower-than-usual response times within the application. Our team is actively working on a fix, and we appreciate your patience.