Incident

Slowness in APIHub

Resolved | Jun 30, 2025 | 13:46 GMT+01:00

The API Hub is now stable, closing this issue after monitoring.

Monitoring | Jun 23, 2025 | 09:03 GMT+01:00

We experienced some slowness in API Hub. The issue has been mitigated for now, and we are investigating the root cause.