Incident

Service disruption in Portal

Resolved | May 22, 2024 | 17:17 GMT+01:00

Start Time: 2024-05-22 16:23:00
We are experiencing slowness and downtime in portal site due to disruption in Azure Service. We're actively working on to resolve this issue. We will share more updates once the issue is resolved.

Thank you for your understanding and continued support.
Should you have any further inquiries or require additional information, please do not hesitate to reach out to our support team.

Resolved Time: 2024-05-22 16:50:00
This issue has been resolved now. We'll share more details shortly.