Incident

Intermittent slowness - US environment

Resolved | Oct 28, 2025 | 00:00 GMT+00:00

The issue was resolved by performing a forced scale-up. We have also implemented measures to ensure that scale-up operations are triggered even in edge cases involving resource constraints.

Monitoring | Oct 16, 2025 | 19:51 GMT+01:00

The services are stable in US environment now and we are monitoring the issue

Open | Oct 16, 2025 | 19:47 GMT+01:00

We encountered an issue with our database in US environment and have temporarily mitigated it by force-scaling the server. The situation is currently being monitored closely.